quinta-feira, 24 de novembro de 2011

MVPN - Inter-AS Opção C

1      Multicast VPN Inter-AS Opção C

Option C—Exchange of VPNv4 routes between route reflectors (RRs) using multihop eBGP peering sessions
The Option C model combines MP-eBGP exchange of VPNv4 routes between route reflectors (RRs) of different autonomous systems with the next hops for these routes exchanged between corresponding ASBR routers. In the Option C model, VPNv4 routes are neither maintained nor distributed by the ASBRs. ASBRs must maintain labeled IPv4 /32 routes to the PE routers within its autonomous system and use eBGP to distribute these routes to other autonomous systems. ASBRs in any transit autonomous systems will also have to use eBGP to pass along the labeled /32 routes. The result is the creation of a LSP from the ingress PE router to the egress PE router.
Because RRs of different autonomous systems will not be directly connected, multihop fuctionality is required to allow for the establishment of the MP-eBGP peering sessions. The exchange of next hops is necessary because the RRs do not reset the next-hop attribute of the VPNv4 routes when advertising them to adjacent autonomous systems because they do not want to attract the traffic for the destinations that they advertise. They are not the original endpoint—just a relay station between the source and receiver PEs. The PE router next-hop addresses for the VPNv4 routes, thus, are exchanged between ASBR routers. The exchange of these addresses between autonomous systems can be accomplished by redistributing the PE router /32 addresses between the autonomous systems or by using BGP label distribution.
Note Option C normally is deployed only when each autonomous system belongs to the same overall authority, such as a global Layer 3 MPLS VPN service provider with autonomous systems in different regions of the world. Option B is equally suited for this purpose and is also deployed in networks where autonomy between different regions is desired.
Nessa solução o MDT precisa ser o mesmo nos dois AS.

1.1       How BGP Sends MPLS Labels with Routes

When BGP (EBGP and IBGP) distributes a route, it can also distribute an MPLS label that is mapped to that route. The MPLS label mapping information for the route is carried in the BGP update message that contains the information about the route. If the next hop is not changed, the label is preserved.

When you issue the neighbor send-label command on both BPG routers, the routers advertise to each other that they can then send MPLS labels with the routes. If the routers successfully negotiate their ability to send MPLS labels, the routers add MPLS labels to all outgoing BGP updates.

Cenário

1.2       Objetivo

Oito roteadores (CE1, PE1, P1, PE2, PE3, P2, PE4 e CE2) são conectados formando dois backbones com 3 roteadores e um CE conectado. Pede-se:
      O protocolo de roteamento de backbone PE1-P1-PE2 deverá ser o OSPF na área 0 com todas as interfaces divulgadas e com mBGP e LDP no AS 1 para tráfego das vpns VRFs. O Router-reflector deverá ser o P1;
      O protocolo de roteamento de backbone PE1-P1-PE2 deverá ser o ISIS na área 49.0001 com todas as interfaces divulgadas e com mBGP e LDP no AS 2 para tráfego das vpns VRFs. O Router-reflector deverá ser o P2;
      Tanto o CE1 quanto o CE2 deverão pertencer a VRF BLUE e deverá existir conectividade entre esses CEs usando a conexão entre os PEs PE2 e PE3 com Inter-AS Opção C;
      Deverá ser habilitado o multicast dentro da VRF BLUE com conectividade entre os CEs.
      O MDT da VRF deverá ser 224.1.2.3;
      O Rendezvous Point do AS 1 deverá ser o PE2 e o do AS 2 o PE3, ambos com conexão MSDP entre eles;
      O RP da VRF deverá ser o CE1 estaticamente;
      O CE1 é source de 227.2.2.2 e o CE2 é fonte deste grupo;
      O CE2 é source de 227.1.1.1 e o CE2 é fonte deste grupo;

1.3       Topologia

1.4       IOS utilizados

      CE1, PE1, P1, PE2, PE3, P2, PE4 e CE2 – c7200-k91p-mz.122-25.S15.bin

1.5       Configuração dos Roteadores

1.5.1        Configurações do ISIS do Backbone

Em todos os roteadores configura-se o roteamento ISIS adicionando o endereçamento NET de acordo com a área designada e endereçamento de loopback. Dentro das interfaces que farão parte do ISIS, adiciona-se o comando “ip router isis” para habilitar o ISIS na interface. Por padrão, todos os roteadores farão vizinhança L1/L2. Pode-se alterar o level na interface ou no roteamento.
A configuração da métrica wide, maior que 63, é feita dentro do processo de roteamento pelo comando “default metric-style wide”.

1.5.2        Configurações do OSPF do Backbone

Em todos os roteadores configura-se o roteamento OSPF pelo comando “router ospf ” onde o “processo” é um numero do processo OSPF. O roteador também possui um router ID único que geralmente é a interface loopback ou então o maior endereço IP do roteador.
Para adicionar interfaces deve-se usar o comando “network
área ”. Um roteador pode ter interfaces em áreas distintas, define-se cada área pelo comando network.
Para o roteador fazer vizinhança OSPF é necessário que a rede da interface esteja no comando “network” e a interface não esteja configurada como “passive-interface”.

1.5.3        Configurações do MPLS

Antes de qualquer configuração, o Cisco Express forwarding deve ser habilitado com o comando “ip cef”. Para habilitar o MPLS no modo LDP, usa-se o comando global “mpls label protocol ldp”.
Para habilitar nas interfaces o LDP para vizinhança, usa-se o comando “mpls ip”.

1.5.4        Configuração do MBGP

Para estabelecer uma VPN é necessário configurar o MBGP para a troca de informações de prefixos de VPN. Pode-se somente configurar o MBGP nos roteadores PEs da rede que possuem conexão com os CEs, ou seja, conectados diretamente aos sites.
O MBGP funciona como o BGP, configura-se em todos os roteadores pelo comando “router bgp onde o “AS” é o Autonomous System do backbone. Dentro da configuração de BGP adicionam-se os vizinhos estaticamente com o comando “neighbor remote-as .
Adiciona-se o IP da interface loopback como Router-ID pelo comando “bgp router-id .
Como os roteadores dentro do mesmo AS não divulgarão as rotas IBGP entre eles, faz-se o full-mesh de conexão MBGP ou configuram-se os roteadores centrais como Router-reflectors adicionando os demais roteadores como clientes pelo comando “neighbor router-reflector-client”.
O MBGP é configurado dentro do protocolo BGP, porém deve-se separar a família de roteamento com o comando “address-family vpnv4”. Para o envio de prefixos das VPNs, deve-se habilitar o envio de community extendida com o comando “neighbor send-community extended”.
Todos os recursos como route-map, next-hop-self, router-reflector, etc. podem ser configurados dentro da família VPNv4 para manipular ou resolver problemas de roteamento.

1.5.5        Criando uma VPN VRF no BGP

Após todos os roteadores PEs da rede possuem conectividade MBGP, ou diretamente ou por router-reflector, cria-se a VPN com o comando “ip vrf ”, dentro desse comando ficam os parâmentros de marcação da VPN e das communities associadas aos prefixos daquela VPN. Configura-se o Route-Distinguisher da VPN, que deve ser único na rede, com comando “rd :”, e também cria-se a  community que será exportada para aqueles prefixos de rede com o comando “route-target :”, onde “import” significa importar as rotas e “export” exportar as rotas.
Cria-se então uma address-family dentro do BGP com o comando “address-family ipv4 vrf ” com o mesmo nome da VPN criada no “ip vrf” fora do roteamento BGP. Dentro dessa address-family são configuradas as redes que serão redistribuídas para os outros sites. Para divulgar as redes é necessário que a rede exista na tabela de roteamento interna e, ou adicionar o comando “network mask ou redistribuindo rotas para o MBGP com o comando “redistribute , que pode ser vinculado à um route-map para definir exatamente as rotas que serão divulgadas de um protocolo para outros sites.
Enfim, para que uma interface conectada ao CE faça parte da VPN BGP, usa-se o comando “ip vrf forwarding ” dentro da interface.

1.5.6        Configuração do Inter-AS Opção C

A opção C do Inter-AS usa uma conexão MBGP entre os roteadores Router-Reflectors de VPN da rede para a troca de informações de prefixos de VPN. Pode-se acordar os mesmos RD e RT ou exportar e importar os RTs do AS vizinho, caso sejam diferentes.
No ASBR deve-se estabelecer uma vizinhança BGP tanto com o RR do próprio AS quanto com o ASBR do AS vizinho, e deve-se adicionar o “send-label” na configuração de vizinhança com todos os roteadores, do AS vizinho e o RR, para que seja enviadas as informações de NLRI e Label.
Na interface de interconexão no ASBR deve-se adicionar o comando para habilitar o mpls BGP “mpls bgp forwarding”.
Deve-se também desabilitar o filtro de route-target do AS no MBGP com o RR do AS vizinho usando o comando “no bgp default route-target filter”.
Para que no Inter-AS o caminho até o source do multicast seja conhecido, deve-se estabelecer a sessão BGP Multicast entre os roteadores de borda “address-family ipv4 multicast”. Nessa sessão deve-se anuncia os endereços dos PEs que terão as fontes multicast ativas.
Na vizinhança com o Router Reflector deve-se adicionar o comando “next-hop-self” para que o ASBR seja o nexthop das rotas externas.

1.5.7        Configuração do Multicast no Backbone

É necessário configurar o roteamento multicast no roteador com o comando “ip multicast-routing”.
No PIM a configuração para o sparse mode é feita a configuração “ip pim sparse-mode” nas interfaces com os roteadores do backbone que trafegarão multicast. O Sparse mode necessita de um Rendevouz Point. Deve-se criar o RP da VRF que deve ser configurado nos PEs com o comando “ip pim rp-address ”.
Para definir o Rendezvous Point do bckbone, usa-se o comando “ip pim rp address ” ou algum modo de eleição (BSR ou Auto-RP).

1.5.8        Configuração do Multicast na VPN

Antes de configurar o PIM é necessário configurar o roteamento multicast no PE com o comando “ip multicast-routing vrf ”. No PIM a configuração para o sparse mode é feita com o comando “ip pim sparse-mode” nas interfaces com os roteadores da VPN que trafegam multicast. O Sparse mode necessita de um Rendevouz Point. A configuração de Rendevouz Point estático é feita pelo comando “ip pim vrf rp-address ”.
Dentro das configurações de VRF deve-se adicionar o grupo multicast que será usado no backbone para o tráfego do multicast da VRF. Essa configuração é feita com “mdt default ”.

1.5.9        Configurações do MSDP entre domínios

A configuração da conexão MSDP é feita entre os RPs com o comando “ip msdp peer [remote-as ]”. Pode ser configurada a interface loopback para fechar a conexão MSDP, basta configura-la como source. O comando “ip msdp cache-sa-state” mantém em cache os grupos e fontes conhecidas.
Configura-se o comando “ip msdp rpf rfc3618” para utilizar os recursos da RFC 3618 do MSDP.
Para configurar um filtro de AS no MSDP usa-se o comando “ip msdp sa-filter list ” a ACL tem que ser extendida. Existem recomendações da Cisco para o uso do filtro de AS que são descritas em documentação.

1.5.10     Configurações do IGMP

O IGMP é configurado em todas as interfaces que estão com o multicast PIM configurado. Caso algum host conectado ao roteador enviar um trafego de “join multicast” o roteador automaticamente passará para o Source daquele grupo, caso exista.
Nesse exemplo pode-se utilizar o comando “ip igmp join-group ” para enviar uma solicitação de join no grupo multicast.

1.6       Observações e Bugs

1.7       Comandos Importantes de Verificação

PE1#show ip pim vrf BLUE rp
Group: 227.1.1.1, RP: 10.10.10.1, v2, uptime 00:08:24, expires never
Group: 227.2.2.2, RP: 10.10.10.1, v2, uptime 00:03:44, expires never
Group: 224.0.1.40, RP: 10.10.10.1, v2, uptime 00:08:26, expires never

PE1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.2.3), 00:12:41/stopped, RP 2.2.2.2, flags: SJCFZ
  Incoming interface: FastEthernet0/0, RPF nbr 11.11.11.100
  Outgoing interface list:
    MVRF BLUE, Forward/Sparse, 00:12:40/00:02:22

(1.1.1.1, 224.1.2.3), 00:12:41/00:03:23, flags: FTZ
  Incoming interface: Loopback0, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 00:10:10/00:02:43

(4.4.4.4, 224.1.2.3), 00:11:14/00:02:53, flags: JTZ
  Incoming interface: FastEthernet0/0, RPF nbr 11.11.11.100
  Outgoing interface list:
    MVRF BLUE, Forward/Sparse, 00:11:14/00:00:48

PE1#show ip mroute vrf BLUE
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 227.2.2.2), 00:10:45/00:03:15, RP 10.10.10.1, flags: SF
  Incoming interface: FastEthernet1/0, RPF nbr 10.10.10.1
  Outgoing interface list:
    Tunnel0, Forward/Sparse, 00:10:45/00:03:15

(10.10.10.1, 227.2.2.2), 00:07:21/00:03:23, flags: FT
  Incoming interface: FastEthernet1/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel0, Forward/Sparse, 00:07:22/00:03:15

2      Configuração

2.1       CE1

!
Hostname CE1
!
Ip cef
Ip multicast-routing
!
interface FastEthernet1/0
 ip address 10.10.10.1 255.255.255.0
 no shutdown
 du full
 ip pim sparse-mode
 ip igmp join-group 227.1.1.1
!
ip route 0.0.0.0 0.0.0.0 10.10.10.254
!        
ip pim rp-address 10.10.10.1
!

2.2       PE1

!
Hostname PE1
!
ip cef
!
!
mpls label protocol ldp
no ip domain-lookup
!
ip vrf BLUE
 rd 1:1
 route-target export 1:1
 route-target import 1:1
 mdt default 224.1.2.3

!
ip multicast-routing
ip multicast-routing vrf BLUE
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip pim sparse-mode
!
interface FastEthernet0/0
 ip address 11.11.11.1 255.255.255.0
 ip pim sparse-mode
 no shutdown
 du full
 mpls ip
!
interface FastEthernet1/0
 ip vrf forwarding BLUE
 ip address 10.10.10.254 255.255.255.0
 no shutdown
 du full
 ip pim sparse-mode
!
router ospf 1
 router-id 1.1.1.1
 network 1.1.1.1 0.0.0.0 area 0
 network 11.11.11.1 0.0.0.0 area 0
!
router bgp 1
 bgp router-id 1.1.1.1
 neighbor 100.100.100.100 remote-as 1
 neighbor 100.100.100.100 update-source Loopback0
 !
 address-family ipv4
 neighbor 100.100.100.100 activate
 neighbor 100.100.100.100 send-label
 neighbor 100.100.100.100 send-community both
!
 address-family vpnv4
 neighbor 100.100.100.100 activate
 neighbor 100.100.100.100 send-community both
 !
 address-family ipv4 vrf BLUE
 redistribute connected
!
ip pim rp-address 2.2.2.2               ! O RP eh o ASBR
ip pim vrf BLUE rp-address 10.10.10.1   ! O RP eh o CE
!

2.3       P1 – Router Reflector

!
Hostname P1-RR
!
ip cef
!
mpls label protocol ldp
ip multicast-routing
!
!
interface Loopback0
 ip address 100.100.100.100 255.255.255.255
 ip pim sparse-mode
!
interface FastEthernet0/0
 ip address 12.12.12.100 255.255.255.0
 ip pim sparse-mode
 no shutdown
 du full
 mpls ip
!
interface FastEthernet1/0
 ip address 11.11.11.100 255.255.255.0
 ip pim sparse-mode
 no shutdown
 du full
 mpls ip
!
router ospf 1
 router-id 100.100.100.100
 network 11.11.11.100 0.0.0.0 area 0
 network 12.12.12.100 0.0.0.0 area 0
 network 100.100.100.100 0.0.0.0 area 0
!
router bgp 1
 bgp cluster-id 1
 bgp router-id 100.100.100.100
 no bgp default ipv4-unicast
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 200.200.200.200 remote-as 2
 neighbor 200.200.200.200 ebgp-multihop 255
 neighbor 200.200.200.200 update-source Loopback0
 !
address-family ipv4
 neighbor 1.1.1.1 activate
 neighbor 1.1.1.1 send-label
 neighbor 1.1.1.1 send-community both
 neighbor 1.1.1.1 route-reflector-client
 neighbor 2.2.2.2 activate
 neighbor 2.2.2.2 send-label
 neighbor 2.2.2.2 send-community both
 neighbor 2.2.2.2 route-reflector-client
 no neighbor 200.200.200.200 activate
!
 address-family vpnv4
 neighbor 1.1.1.1 activate
 neighbor 1.1.1.1 route-reflector-client
 neighbor 1.1.1.1 send-community both
 neighbor 200.200.200.200 activate
 neighbor 200.200.200.200 next-hop-unchanged
 neighbor 200.200.200.200 send-community both
!
ip pim rp-address 2.2.2.2
!

2.4       PE2 – ASBR

!
Hostname PE2-ASBR
!
mpls label protocol ldp
ip cef
!
ip multicast-routing
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip pim sparse-mode
!
interface FastEthernet0/0
 ip address 23.23.23.2 255.255.255.0
 ip pim sparse-mode
 no shutdown
 du full
 no ip mroute-cache
 no ip route-cache
 mpls bgp forwarding
!
interface FastEthernet1/0
 ip address 12.12.12.2 255.255.255.0
 ip pim sparse-mode
 mpls ip
 no shutdown
 du full
 no ip mroute-cache
 no ip route-cache
!
router ospf 1
 router-id 2.2.2.2
 redistribute bgp 1 subnets route-map bgp2ospf
 network 2.2.2.2 0.0.0.0 area 0
 network 12.12.12.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0
 passive-interface FastEthernet0/0
!
router bgp 1
 bgp router-id 2.2.2.2
 neighbor 23.23.23.3 remote-as 2
 neighbor 100.100.100.100 remote-as 1
 neighbor 100.100.100.100 update-source lo0
 !
 address-family ipv4
 neighbor 100.100.100.100 activate
 neighbor 100.100.100.100 send-label
 neighbor 100.100.100.100 next-hop-self
 neighbor 23.23.23.3 activate
 neighbor 23.23.23.3 send-label
 neighbor 23.23.23.3 route-map LABEL-IN in
 neighbor 23.23.23.3 route-map LABEL-OUT out
 network 100.100.100.100 mask 255.255.255.255
 network 1.1.1.1 mask 255.255.255.255
!
ip pim rp-address 2.2.2.2
ip msdp peer 23.23.23.3
ip msdp cache-sa-state
!
!
access-list 1 permit 1.1.1.1 log            ! IP Loopback PE1
access-list 2 permit 4.4.4.4 log            ! IP Loopback PE2
access-list 3 permit 100.100.100.100 log    ! IP Loopback P1 RR
access-list 4 permit 200.200.200.200 log    ! IP Loopback P2 RR
!
!
route-map LABEL-IN permit 10                ! aceita rotas com label do PE2 do AS 2
 match ip address 2
 match mpls-label
!
route-map LABEL-IN permit 11                 ! aceita rotas do RR do AS 2
 match ip address 4
!
!
route-map LABEL-OUT permit 12                ! envia rotas do RR local
 match ip address 3
!
route-map LABEL-OUT permit 13                ! envia rotas do PE1 com label
 match ip address 1
 set mpls-label
!

2.5       PE3 – ASBR

!
Hostname PE3-ASBR
!
ip cef
!
mpls label protocol ldp
ip multicast-routing
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip router isis
!
interface FastEthernet0/0
 ip address 32.32.32.3 255.255.255.0
 ip pim sparse-mode
 ip router isis
 no ip mroute-cache
 no ip route-cache
 no shutdown
 du full
 mpls ip
!
interface FastEthernet1/0
 ip address 23.23.23.3 255.255.255.0
 ip pim sparse-mode
 no ip mroute-cache
 no ip route-cache
 ip router isis
 no shutdown
 du full
 mpls bgp forwarding
!
router isis
 net 49.0001.3333.3333.3333.00
 is-type level-2-only
 passive-interface FastEthernet1/0
!
router bgp 2
 bgp router-id 3.3.3.3
 neighbor 23.23.23.2 remote-as 1
 neighbor 200.200.200.200 remote-as 2
 neighbor 200.200.200.200 update-source lo0
 !
 address-family ipv4
 neighbor 200.200.200.200 activate
 neighbor 200.200.200.200 send-label
 neighbor 200.200.200.200 next-hop-self
 neighbor 23.23.23.2 activate
 neighbor 23.23.23.2 send-label
 neighbor 23.23.23.2 route-map LABEL-IN in
 neighbor 23.23.23.2 route-map LABEL-OUT out
 network 4.4.4.4 mask 255.255.255.255
 network 200.200.200.200 mask 255.255.255.255
!       
ip pim rp-address 3.3.3.3
ip msdp peer 23.23.23.2
ip msdp cache-sa-state
!
!
access-list 1 permit 1.1.1.1 log            ! IP Loopback PE1
access-list 2 permit 4.4.4.4 log            ! IP Loopback PE2
access-list 3 permit 100.100.100.100 log    ! IP Loopback P1 RR
access-list 4 permit 200.200.200.200 log    ! IP Loopback P2 RR
!
!
route-map LABEL-IN permit 10                 ! aceita rotas com label do PE1 do AS 1
 match ip address 1
 match mpls-label
!
route-map LABEL-IN permit 11                 ! aceita rotas do RR do AS 1
 match ip address 3
!
!
route-map LABEL-OUT permit 12                ! envia rotas do RR local
 match ip address 4
!
route-map LABEL-OUT permit 13                ! envia rotas do PE1 com label
 match ip address 2
 set mpls-label
!

2.6       P2 – Router Reflector

!
Hostname P2-RR
!
ip cef
!
mpls label protocol ldp
ip multicast-routing
!
!
interface Loopback0
 ip address 200.200.200.200 255.255.255.255
 ip pim sparse-mode
 ip router isis
!
interface FastEthernet0/0
 ip address 24.24.24.200 255.255.255.0
 ip pim sparse-mode
 ip router isis
 no shutdown
 du full
 mpls ip
!
interface FastEthernet1/0
 ip address 32.32.32.200 255.255.255.0
 ip pim sparse-mode
 ip router isis
 no shutdown
 du full
 mpls ip
!
router isis
 net 49.0001.2222.2222.2222.00
 is-type level-2-only
!
router bgp 2
 bgp router-id 200.200.200.200
 neighbor 4.4.4.4 remote-as 2
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 3.3.3.3 remote-as 2
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 100.100.100.100 remote-as 1
 neighbor 100.100.100.100 ebgp-multihop 255
 neighbor 100.100.100.100 update-source Loopback0
 !
 address-family ipv4
 neighbor 4.4.4.4 activate
 neighbor 4.4.4.4 send-label
 neighbor 4.4.4.4 route-reflector-client
 neighbor 4.4.4.4 send-community extended
 neighbor 3.3.3.3 activate
 neighbor 3.3.3.3 send-label
 neighbor 3.3.3.3 route-reflector-client
 neighbor 3.3.3.3 send-community extended
 no neighbor 100.100.100.100 activate
 !
 address-family vpnv4
 neighbor 4.4.4.4 activate
 neighbor 4.4.4.4 route-reflector-client
 neighbor 4.4.4.4 send-community both
 neighbor 100.100.100.100 activate
 neighbor 100.100.100.100 next-hop-unchanged
 neighbor 100.100.100.100 send-community both
!
ip pim rp-address 3.3.3.3
!

2.7       PE4

!
Hostname PE4
!
ip cef
!
mpls label protocol ldp
ip vrf BLUE
 rd 1:1
 route-target export 1:1
 route-target import 1:1
 mdt default 224.1.2.3
!
ip multicast-routing
ip multicast-routing vrf BLUE
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip pim sparse-mode
 ip router isis
!
interface FastEthernet0/0
 ip vrf forwarding BLUE
 ip address 20.20.20.254 255.255.255.0
 ip pim sparse-mode
 no shutdown
 du full
!
interface FastEthernet1/0
 ip address 24.24.24.4 255.255.255.0
 ip pim sparse-mode
 ip router isis
 mpls ip
 no shutdown
 du full
!
router isis
 net 49.0001.4444.4444.4444.00
 is-type level-2-only
!
router bgp 2
 bgp router-id 4.4.4.4
 neighbor 200.200.200.200 remote-as 2
 neighbor 200.200.200.200 update-source Loopback0
 !       
 address-family ipv4
 neighbor 200.200.200.200 activate
 neighbor 200.200.200.200 send-label
 neighbor 200.200.200.200 send-community both
 !
 address-family vpnv4
 neighbor 200.200.200.200 activate
 neighbor 200.200.200.200 send-community both
!
 address-family ipv4 vrf BLUE
 redistribute connected
!
ip pim rp-address 3.3.3.3
ip pim vrf BLUE rp-address 10.10.10.1   ! O RP eh o CE
!

2.8       CE2

!
Hostname CE2
!
interface FastEthernet1/0
 ip address 20.20.20.2 255.255.255.0
 no shutdown
 du full
 ip pim sparse-mode
 ip igmp join-group 227.2.2.2
!
ip route 0.0.0.0 0.0.0.0 20.20.20.254
!
ip pim rp-address 10.10.10.1
!

2 comentários:

Anônimo disse...

When someonе ωritеs an pieсe
of ωrіtіng he/ѕhe maіntаins the imagе of a user in his/hеr bгаin that how a usеr
can bе awаre of it. Theгefоrе
that's why this piece of writing is great. Thanks!

Feel free to visit my page - chatroulett

Aaron paul disse...

Thanks for sharing this informative information. There are many companies offers all the practice equipments essential to clear the CCIE Lab Exam in Routing and Switching, CCIE Security, and Service Provider. Expect to find the most up to date rack hardware, engaging mockup labs, and relevant workbooks for all your CISCO exam needs. Pass CCIE exam with Workbooks, Video and Audio on Demand Courses, Rack Rental and Bootcamps from CCIE Certification training provider!