terça-feira, 30 de março de 2010

ISIS Básico 1


1.1      Características do ISIS

O ISIS é um protocolo de roteamento dinâmico flexível e escalável que utiliza o empilhamento OSI com suporte a roteamento IP e OSI. Utiliza áreas para formar topologias hierárquicas suportando mais de 1000 routers por área com detecção de falhas, processamento de LSA e complexibilidade melhores que o OSPF.
Todos os routers IS-IS têm que ter comunicação com os demais (FULL-MESH) funcionando com vários circuitos ponto a ponto em redes NBMA. O roteamento é aplicado na interface e não possui comando “network” para divulgação de redes.
Faz eleição de Dedicated Router (DIS) como o OSPF, mas não possui BDR. Eleição ocorre sempre que um novo router entra na rede.   Um router só pode pertencer a uma área, sendo que ele pode possuir a tabela de outro level quando ele for borda (L1/L2). As métricas usadas são Default, Delay, Expense e Error sendo a Default utilizada.

1.2      Terminologia do ISIS

·         ES – Sistema Final (End System). Todos os sistemas que não forem routers. Hosts;
·         IS – Sistema intermediário (Intermediate System). São os routers;
·         Domain – É uma coleção de áreas conectadas;
·         CLNS – Conectionless Network Service, não precisa de circuito estabelecido, não é orientado. É o equivalente do IP no modelo OSI;
·         CLNP - Connectionless Network Protocol, Protocolo do modelo OSI não orientado a conexão. Equivalente do IP no modelo OSI que provê a interface entre o CLNS e as camadas superiores;
·         CMNS– Connection-Mode Network Service, Orientado a conexão e precisa de circuito estabelecido. Sua função inclui ajustar, manter e fechar as conexões. Usado em QoS;
·         CONP - Connection-Oriented Network Protocol, Protocolo do modelo OSI orientado a conexão. Provê a interface entre o CMNS e as camadas superiores;
·         NSAP – É o endereçamento OSI individual que todo router IS-IS requer.;
·         IS-IS – Roteamento entre sistemas intermediários:
·         level 1 - Roteamento entre sistemas Intermediários de mesma área;
·         level 2 - Roteamento entre sistemas Intermediários de áreas diferentes;
·         level 3 - Roteamento entre sistemas Intermediários de Domínios Diferentes.
·         ESH – Pacote de flood enviado pelos ES aos IS;
·         ISH – Pacote de flood enviado pelos IS para o ES;
·         IIS – Pacote de flood envidado de IS para IS;
·         DIS – Designated Intermediate System gera as LSP (Link-State Packet) para todos os routers.

1.3      Roteamento do ISIS

·         O roteamento começa quando um ES descobre o IS que enviar o primeiro pacote ISH;
·         Quando um ES quer mandar um pacote para outro ES, ele envia para um IS da rede (Level-0 routing);
·         O IS conhece os ES’s da rede por escutar os pacotes ESH (End System Hello), recebe o pacote e, no caso do ES estiver no mesmo segmento ele responde para o ES de origem que o ES de destino está diretamente disponível. Já se o ES estiver em outro segmento (subrede), o IS vai conhecer o router correto e vai encaminhar (Level-1 routing);
·         Se o endereço de destino estiver em um ES de outra área o IS Level-1 envia o pacote para o IS L1/L2 mais próximo (Level-2 routing);
·         O encaminhamento de IS Level-2 para IS Level-2 só pára quando o pacote chegar à área de destino onde ele encontrará o menor caminho para o ES;
·         O roteamento entre domínios separados é Level-3 routing. Os Dominios são equivalentes a AS’s;


1.4      Estrutura do endereçamento NSAP

IDP – Inter-Domain Part – É o endereçamento completo. Seria o IP classfull no IP. 1 à 13 bytes.
DSP – Domain-Specific Part – Parte específica do domínio.
AFI Authority and Format ID – Formato do endereçamento
Private - 49
E.164 – 45
DCC – US 39
ICD - 47
IDI – Inter-Domain ID – Identificação do Domínio
High Order DSP HODSP– Usado para subdividir o domínio em áreas. Parecido com as subnets do IP.
Pouco usado.
System ID – Identifica um dispositivo individual no OSI, pode ser o MAC ou o endereço IP da loopback convertido.
6 bytes.
NSEL – NSAP-Selector – Identifica o processo no dispositivo. Parecido com a porta do Socket no IP. Não é usado nas decisões de rotas (00)
1 byte.
Tipo 3
Tipo 2
Tipo 1

Mínimo de 8 bytes e máximo de 20 bytes.
O endereço NSAP é do formato XX.YYYY.ZZZZ.aaaa.bbbb.cccc.KK sendo que XX.YYYY pode ser maior, por isso é bom contar da direita para esquerda:

XX.
YYYY.
aaaa.bbbb.cccc.
KK
ISO-IGRP
Domain-ID
Area-ID
System ID, que é o MAC do router
Ignorado pelo ISO-IGRP
IS-IS
Area-ID
System ID, que é o MAC do router
NSEL (NSAP Selector)
·         O ISO-IGRP é o protocolo proprietário da Cisco para roteamento CLNS.
·         O endereço NET é a identificação do router podendo ser até 3 e têm os valores de KK como 00;
·         Todos os routers da mesma área têm que ter o mesmo endereço de área;
·         O roteamento entre áreas (Level-1) é baseado no System ID e deve ser único entre áreas e domínios (Mac Address);
·         O system ID pode ser o endereço de loopback convertido – 192.168.11.3 -> 192.168.011.003 -> 1921.6801.1003;
·         Todos os IS’s Level-2 tem que ter conhecimento de todos os IS’s Level-2 do Backbone;
·         Os endereços IP’s são relevantes. O ISIS cria adjacências com os vizinhos baseado no NSAP e não no IP.

1.5      Estrutura de Áreas

O ISIS é dividido em domínios parecidos com AS’s e esses AS’s são divididos em áreas. As estruturas de áreas são subdivididas em dois níveis hierárquicos sendo que um router pertence sempre a uma única área, diferente do OSPF (ABR);
·         Level-1 IS’s (L1) – Equivalente a área não-backbone do OSPF, faz roteamento para os ES’s dentro da área. Um grupo de routers L1 define uma área e somente aceita adjacências de L1 e L1/L2;
·         Level-2 IS’s (L2) – Equivalente aos backbone routers do OSPF. Faz roteamento entre áreas apenas. Possui uma Database diferente e somente aceita adjacência de L2 e L1/L2;
·         Level-1-2 Intermediate IS’s (L1/L2) – Equivalente aos routers de borda do OSPF (ABR), fazem roteamento entre as áreas e o backbone. Intra-area Level-1 e Inter-area Level-2. Mantém duas copias separadas do Link-State DataBase, a de L1 e a de L2. Informa a todos os L1 um ponto de saída da área (ele mesmo enviando a informação em um bit no LSP L1). Os routers L1 e L2 sempre procuram os L1/L2 mais próximos para sair da área, e são nos L1/L2 que ocorre a sumarização manual.

1.6      Eleição de DIS e Operação

·         O DIS é eleito pela preferência, default = 64 e configuravel de 0 a 127, pelo MAC mais alto, em redes Frame-Relay é eleito pelo DLCI mais alto e se todos forem iguais é eleito pelo maior System ID.
·         Funciona como o DR no OSPF, mas não possui BDR. Usa um Hello de DIS de 3.3s, 1/3 mais rápido que os hello’s para detecção mais rápida;
·         Quando um novo router entra na rede ocorre nova eleição;
·         DIS não sincroniza LSPs com os vizinhos, cada vizinho envia LSP para todos os vizinhos por multicast;
·         Existe um DIS para L1 e um para L2.

1.7      Configuração da Rede IS-IS

·         Habilita o roteamento ISIS com um tag, se não for colocado nenhum tag ele considera o 0 (zero);
·         Configura o endereço NET com o numero da área (49.000), MAC address ou loopback e o NSAP (00) ex: 49.000.1921.6801.0003.00;
·         Coloca a interface loopback como passiva para não enviar LSP;
·         Habilita o tipo de roteador IS-IS, se L1, L2 ou L1/L2 (default);
·         Habilita o IS-IS nas interfaces que farão parte do IS-IS. As redes são divulgadas automaticamente das redes das interfaces;
·         Coloca na interface o tipo de adjacência que ela terá pela aquela interface, se L1, L2 ou L1/L2 (default).

2        Cenário

2.1      Objetivo

Três roteadores (PE1, PE2 e PE3) são conectados, sendo o PE2 o único roteador que possui conexão com os demais. O objetivo é estabelecer uma conexão ISIS level 1 entre o PE1 e o PE2 e uma conexão Level 2 entre o PE2 e o PE3.
O endereço IP das loopbacks de cada roteador deverá ser acessível por todos os roteadores, ou seja, deve-se fazer a distribuição entre os levels no PE2.
As áreas ISIS são: 49.0012 para a área Level 1 e 49.0003 para o PE3.

2.2      Topologia

Figure-01:              Topologia

2.3      IOS utilizados

·         PE1, PE2 e PE3 – c7200-itp-mz.122-25.SW4a.bin

2.4      Descrição do Cenário

Avaliar a configuração básica inicial do protocolo de roteamento ISIS, tanto para o level 1 quanto para o level 2, além de rotear entre eles usando um roteador level-1-2.
Sugerem-se as seguintes atividades:
·         Teste de conectividade (PING) entre os roteadores;
·         Alteração dos parâmetros de endereçamento NET e área.

2.5      Configuração dos Roteadores

O roteamento ISIS, independente da área e level, é configurado pelo comando “router Isis” e não possui o número de área no comando principal como o OSPF. Dentro da configuração de roteamento é onde é adicionado o endereço NSAP, que é o endereço único do roteador no ISIS. Esse endereço é configurado pelo comando “net” e se deve atentar para o formato do endereço, que segue normalmente o padrão “49.XXXX.loopback.00. O “49” indica ser uma área privada e o “loopback” segue a forma de escrever um endereço IP no formato MAC.
Por padrão, todos os roteadores são Level-1-2. Deve-se alterar o level do roteador dentro do “router Isis”.

2.6      Observações e Bugs

Documentação:
http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfisis.html

2.7      Comandos Importantes de Verificação

PE2#show clns protocol

IS-IS Router:
  System Id: 0000.0000.0002.00  IS-Type: level-1-2
  Manual area address(es):
        49.0012
  Routing for area address(es):
        49.0012
  Interfaces supported by IS-IS:
        FastEthernet2/0 - IP
        FastEthernet1/0 - IP
  Redistribute:
    static (on by default)
  Distance for L2 CLNS routes: 110
  RRR level: none
  Generate narrow metrics: level-1-2
  Accept narrow metrics:   level-1-2
  Generate wide metrics:   none
  Accept wide metrics:     none

PE2#show isis neighbors

System Id      Type Interface IP Address      State Holdtime Circuit Id
PE1            L1   Fa1/0     12.12.12.1      UP    23       PE2.01            
PE3            L2   Fa2/0     23.23.23.3      UP    8        PE3.01   


PE2#show isis topology

IS-IS IP paths to level-1 routers
System Id            Metric     Next-Hop             Interface   SNPA
PE1                  10         PE1                  Fa1/0       ca00.0fe8.001c
PE2                  --

IS-IS IP paths to level-2 routers
System Id            Metric     Next-Hop             Interface   SNPA
PE2                  --
PE3                  10         PE3                  Fa2/0       ca02.0fe8.0038

PE2#show clns is-neighbors

System Id      Interface   State  Type Priority  Circuit Id         Format
PE1            Fa1/0       Up     L1   64        PE2.01             Phase V
PE3            Fa2/0       Up     L2   64        PE3.01             Phase V

3        Configuração

3.1      PE1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 ip address 12.12.12.1 255.255.255.0
 ip router isis
!
router isis
 net 49.0012.0000.0000.0001.00
 is-type level-1
 passive-interface Loopback0
!

3.2      PE2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
 ip address 12.12.12.2 255.255.255.0
 ip router isis
!
interface FastEthernet2/0
 ip address 23.23.23.2 255.255.255.0
 ip router isis
!
router isis
 net 49.0012.0000.0000.0002.00
 redistribute connected route-map conn2isis level-1-2
!
route-map conn2isis permit 10
 match interface Loopback0
!

3.3      PE3

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet2/0
 ip address 23.23.23.3 255.255.255.0
 ip router isis
!
router isis
 net 49.0003.0000.0000.0003.00
 is-type level-2-only
 passive-interface Loopback0
!

Um comentário:

Andre Luis Antonio disse...

Muito obrigado pelo post, foi de grande utilidade.

Ainda não tenho exeriência de trabalho com esse protocolo.