terça-feira, 30 de abril de 2013

AToM – Ethernet sobre MPLS com ligação de interface

O Any Transport over MPLS (AToM) é uma solução usada para transportar pacotes L2 através de um backbone MPLS. O AToM permite a conectividade entre os sites dos clientes com suas tecnologias L2 existentes através da infraestrutura de rede baseada em pacote.
Com a tecnologia AToM o aprovisionamento e a conectividade são diretas. Um cliente usando Ethernet num edifício ou campus em um local pode se conectar por meio de um provedor via Ethernet sobre MPLS a clientes em locais remotos.
AToM estabelece um quadro comum para encapsular e transportar trafegos Layer 2 sobre a rede MPLS. Os provedores podem usar uma infra-estrutura única MPLS para oferecer aos clientes a conectividade Layer 2.
O AToM suporta os tipos de transporte abaixo:
      ATM AAL5 over MPLS
      ATM Cell Relay over MPLS
      Ethernet VLAN over MPLS
      Frame Relay over MPLS
      PPP over MPLS
      HDLC over MPLS

Ethernet over MPLS

O transporte do L2 funciona através do encapsulamento Ethernet PDUs em pacotes MPLS e encaminha-os através da rede MPLS. Cada PDU é transportado como um único pacote. As seguintes etapas descrevem o processo de encapsular o PDU.

Ingress PE Router

      O PE de entrada recebe o PDU e remove o preamble, o delimitador do frame (SFD), e o frame check sequence (FCS). O resto do cabeçalho permanece o mesmo.
      O PE copia o codigo de controle do cabeçalho, mesmo que não seja usado, adiciona um label VC e um label do túnel LSP para o roteamento normal do MPLS através do backbone. A rede roteia os dados usando o tunnel LSP convencional do MPLS sem distinguir o tipo de tráfego.

 

Egress PE Router

      O PE de destino recebe o pacote e remote o label do LSP, caso exista (Penultimo geralmente retira), retira o label de controle e o label do VOCÊ;
      O PE atualiza o cabeçalho se necessário e envia o pacote para o CE associado.


Cenário

Objetivo

Cinco roteadores (CE1, PE1, P, PE2 e CE2) são conectados formando um backbone com 3 roteadores e dois CEs conectados. Pede-se:
      O protocolo de roteamento de backbone PE1-P-PE2 deverá ser o OSPF na área 0 com todas as interfaces divulgadas e com LDP entre os PEs para tráfego MPLS;
      O CE1 e o CE2 e deverão se comunicar via o backbone usando túnel AToM.

 

Topologia

 

IOS utilizados

      CE1, PE1, P, PE2 e CE2 – c7200-k91p-mz.122-25.S15.bin

 

Configuração dos Roteadores

 Configurações do OSPF do Backbone

Em todos os roteadores configura-se o roteamento OSPF pelo comando “router ospf ” onde o “processo” é um numero do processo OSPF. O roteador também possui um router ID único que geralmente é a interface loopback ou então o maior endereço IP do roteador.
Para adicionar interfaces deve-se usar o comando “network área”. Um roteador pode ter interfaces em áreas distintas, define-se cada área pelo comando network e o tipo da área com o comando “area [type]”.

 

Configurações do MPLS

Antes de qualquer configuração, o Cisco Express forwarding deve ser habilitado com o comando “ip cef”. Para habilitar o MPLS no modo LDP, usa-se o comando global “mpls label protocol ldp”.
Para habilitar o MPLS nas interfaces, configura-se “mpls ip”.

 

Configuração do Túnel AToM

O tunnel L2 AToM é configurado na interface do PE conectada diretamente ao CE com o comando “xconnect encapsulation mpls”. O ID do VOCÊ tem que ser o mesmo nos dois PEs.

 

Observações e Bugs

 

Comandos Importantes de Verificação

PE1#sh xconnect all detail
Legend: XC ST=Xconnect State, S1=Segment1 State, S2=Segment2 State
UP=Up, DN=Down, AD=Admin Down, IA=Inactive, NH=No Hardware
XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP     ac   Fa1/0(Ethernet)              UP mpls 2.2.2.2:100                  UP
            Interworking: none                   pw-class:              

CE1#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID            Local Intrfce         Holdtme   Capability    Platform   Port ID
CE2                 Fas 1/0               135            R        7206VXR   Fas 1/0


 

Configuração

 

CE1

!
interface FastEthernet1/0
 ip address 10.10.10.1 255.255.255.0
!

 

 PE1

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 xconnect 2.2.2.2 100 encapsulation mpls
!
interface FastEthernet2/0
 ip address 13.13.13.1 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 1.1.1.1
 network 1.1.1.1 0.0.0.0 area 0
 network 13.13.13.1 0.0.0.0 area 0
!

 

P

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
 ip address 13.13.13.3 255.255.255.0
 mpls ip
!
interface FastEthernet2/0
 ip address 23.23.23.3 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 3.3.3.3
 network 3.3.3.3 0.0.0.0 area 0
 network 13.13.13.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
!

 

 PE2

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
 xconnect 1.1.1.1 100 encapsulation mpls
!
interface FastEthernet2/0
 ip address 23.23.23.2 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0
!

 

CE2

!
interface FastEthernet1/0
 ip address 20.20.20.1 255.255.255.0
!

7 comentários:

Anônimo disse...

The shoes may seem to be a little expensive but you can avail the Toms Shoes Coupons to get them on fabulous discounts. You can also shop the Toms shoes from various physical retail shoe stores around the United States, but the best and the most convenient way to buy toms shoes is to shop them from an Online Coupon Codes website like Couponrefund.com etc.Are you a TOMS Shoes enthusiast like us? Always wondered what TOMS Shoes is all about? Let us answer all your questions about TOMS Shoes now.[url=http://www.cheaptomsbuy.com]Cheap Toms[/url] Another popular type of leather used in the making of quality footwear is calfskin which comes from young cattle usually younger than four weeks old. This type of leather is used almost exclusively in higher quality mens and womens dress shoes and can be more than twice as expensive as regular side leather.How much does shipping and handling cost? Shipping cost is automatically calculated at checkout and will vary depending on the number of items purchased, where your order is being shipped and the type of shipping chosen. Please review the order total before confirming your purchase. [url=http://www.onlinetomsoutlet.com]Toms Outlet[/url] The management has taken every single step to ensure that the working conditions are favorable for the labors. Everything right form the number of working hours to the worker"s compensation is decided keeping in mind the interests of the workers. They also make sure that no children are employed so as to curb child employment and exploitation. Aside from that, Toms are incredibly comfortable. Theyre made with children in mind so delicate feet are definitely taken into consideration. Whether youre taking a walk or going on a run, Toms are sure not to disappoint. Theyre engineered to be durable as well since they were created knowing that the children who would use them might be walking on rough terrain. Youll be making a good investment on shoes that are built to last. Its definitely well-worth your money to buy these shoes especially considering the fact that your purchase ends up benefitting an incredibly good cause for the future. [url=http://www.tomsfans.com]Cheap Toms Sale[/url] The shoes are calamus weight and actual accidental in looks. The central exceptional superior covering and alfresco elastic sole makes the shoes actual adequate and as well keeps them warm. They are absolute for an accepted circadian base use. There is a lot of accepted appearance is Cordones which are best for jailbait women. Its the American acclaimed cast which is originally advised for poor children. After a few hours of wearing TOMS, they will stretch slightly to conform to your feet. Please try your TOMS on a carpeted surface to keep them as clean as possible until you know they are the correct size. We do not accept returns or size exchanges on shoes that show wear or use.
Relate Post
[url=http://www.dskweb.net/Guestbook/addguest.html]best toms high quality for you discount sale [/url]
[url=http://voodoodr06.wordpress.com/2011/07/27/blogs-that-i-read/]toms sale high quality for you discount sale [/url]

Anônimo disse...

Fiгst of all I ωould lіke tο
say great blog! I had а quicκ queѕtion іn which
I'd like to ask if you do not mind. I was curious to find out how you center yourself and clear your thoughts prior to writing. I have had a difficult time clearing my mind in getting my thoughts out there. I truly do take pleasure in writing but it just seems like the first 10 to 15 minutes tend to be lost just trying to figure out how to begin. Any ideas or tips? Kudos!

Check out my weblog click through the up coming website page

Anônimo disse...

Grеаt gooԁs from уou, man. I have take intο
acсout your stuff prevіous to аnd you
are just tοo fantаstic. I actuаlly like ωhat you've received right here, really like what you're sаying
and the way through which you saу it.
You make it enjoyable and you contіnue to сare for tο keep it smart.

I сan not wait to reaԁ fаr mοre from уou.
Τhat iѕ aсtuаlly a wonderful website.



Feеl fгeе to visit my webpage - Kreisrunder Haarausfall

Anônimo disse...

The articleice Machines introduces:This article about How To Buy Commercial Ice Machines For Restaurant,With the introduction of cutting edge and innovative technologies, a commercial ice machine is no longer a bulky device producing insanitation, consuming a lot ...

If you need more ice Machines infomation about How To Buy Commercial Ice Machines For Restaurant, Click here to find.

With the introduction of cutting ice Machines edge and innovative technologies, a commercial ice machine is no longer a bulky device producing insanitation, consuming a lot of energy, making noise, and taking a lot of time to make the needed supply of ice. As a result of high end technologies, commercial ice machines are able to achieve “being green” the highest levels of energy and water conservation. Now a commercial ice machine can easily produce from 65 pounds to 2,000 pounds of ice cubes in a day. You can find varied shapes of ice cubes such as dice, half dice, octagon, crushed, nugget, and flake.

Commercial ice machines are the standalone units,ice Machines designed to produce large quantities of ice for various commercial purposes. Once installed, these commercial ice makers are pretty automatic and do not need much attention from you or your staff. These factory-made machines consist of a condensing unit and ice-making section that operates as an integrated unit to make ice, an ice bin or a storage unit to store the created ice and a dispensing unit to dispense the ice out of the machine. Many automatic ice machines use moving water to create an improved quality of ice cubes. They work on the principle of “faster the water moves the better the ice quality becomes”. In this process, the air and un-dissolved solids get washed away. This results in pure and clear ice production.

Large amounts of ice are demanded for various purposes in many ice Machines commercial entities such as Restaurants, Bars, Ice Cream Parlors, Bakeries, Country Clubs and Golf Courses. A commercial ice machine is the perfect choice for such places as the large quantity of ice also needs to be a certain quality as well. Automatic commercial ice machines will make plenty of ice of equal size in a short span of time. All you need to do is just start the machine and set the required functions, and leave the rest up to the machine. You will get good quantity of quality ice in a short amount of time. In addition, many commercial ice machines come with a self cleaning function. This will help maintain the quality and quantity if the produced ice while decreasing the time that you and or your staff must spend with the machine.

Keep in mind that there are two varieties of ice machines: air cooled and waterice Machines cooled. Air cooled ice machines use air to disperse the heat, whereas water cooled ice machine uses water to do the same function. Air cooled ice machines use more energy and also are much noisier than water cooled ice machines. However, they are more affordable than water cooled ice machines.

An assorted collection of wonderful, fast and energy efficient commercial ice makers are readilyice Machines available in the market. Various renowned and reliable manufacturers have come up with their unique range of these amazing machines. Numerous models that create different types and sizes of ice are available in the local and online market. A competitive urge of creating more efficient and cost effective ice machines, has left the customers and consumers with a distinctive variety of these units in which to choose.

Aaron paul disse...

CCIE Bootcamps and Training programs are very good to get the good information about Routers, switches and other networking devices. I think these on-line programs provide excellent information that helps a lot to crack the CCIE certification.so I would say its great to join CCIE Rack Rentals programs

Anônimo disse...

Hi are using Wordpress for your site platform? I'm new to the blog world but I'm trying to get started and create my own.
Do you need any html coding knowledge to make your own blog?

Any help would be really appreciated!

my web-site: acai ultra lean

Anônimo disse...

Нi there! This post coulԁ not
bе ωritten much better! Lookіng аt this
pоst reminds mе of mу previous roommate!
He сontinuallу kеpt prеaching about thіѕ.

I am going to fоrward thіѕ information to hіm.
Pгеtty sure hе'll have a good read. Many thanks for sharing!

Also visit my web page; Visit Website