sábado, 4 de setembro de 2010

Traffic Engineering - VPN sobre TE


1        Cenário

1.1           Objetivo

Sete roteadores (CE1, PE1, P1, P2, PE2 e CE2) são conectados fisicamente conforme a topologia abaixo via interfaces Fast Ethernet. Pede-se as configurações abaixo:
         Deverá ser usado o encaminhamento via MPLS entre todos os roteadores;
         Um túnel MPLS deverá ser criado no PE1 para o P2 usando Traffic Engineer para encaminhamento de tráfego dinamicamente baseado no IGP;
         Deverá ser configurada uma VPN com nome “aqua” ligando o CE1 ao CE2. RD e RT a escolher;
         O protocolo de roteamento deverá ser o ISIS na área 47.1234.

1.2           Topologia

Figure-01:              Topologia

1.3           IOS utilizados

         CE1, PE1, P1, P2, PE2, CE2 – c7200-k91p-mz.122-25.S15.bin

1.4           Configuração dos Roteadores

1.4.2      Configurações do MPLS

Antes de qualquer configuração, o Cisco Express forwarding deve ser habilitado com o comando “ip cef”. Para habilitar o MPLS no modo LDP, usa-se o comando global “mpls label protocol ldp”, para que seja habilitado nas interfaces, usa-se esse comando dentro da interface.
O Router-ID usado no MPLS pode ser configurado com o comando “mpls ldp router-id ”.

1.4.3      Configurações do Túnel de TE com OSPF

Para configurar um túnel MPLS TE inicialmente cria-se a interface túnel com o comando “interface tunnel ”, dentro da interface adiciona-se um endereçamento IP, geralmente usa-se um endereço da loopback com o comando “ip unnumbered Loopback0”. Em seguida configura-se o IP do roteador de destino com o comando “tunnel destination ”. Aplica-se então o modo de túnel como MPLS com TE com o comando “tunnel mode mpls traffic-eng”, e após, habilita-se o caminho dinâmico pelo túnel com o comando “tunnel mpls traffic-eng path-option dynamic”. Ainda dentro da interface túnel é habilitado o autoroute para que ele seja considerado pelo IGP, com o comando “tunnel mpls traffic-eng autoroute announce”.
Para o uso do MPLS TE aplica-se globalmente o comando “mpls traffic-eng tunnels”, em todas as interfaces, adiciona-se o comando “mpls traffic-eng tunnels”, esse comando permite a sinalização de TE nas interfaces.
Dentro do protocolo ISIS deve ser adicionada a loopback do router-ID para Traffic-Engineer com o comando “mpls traffic-eng router-id Loopback0” e habilitar o TE para o level de roteamento ISIS “mpls traffic-eng level-2, configura-se os dois levels no traffic-eng caso o roteador seja L1/L2.

1.4.4      O uso da VPN com MPLS TE

Caso o túnel seja destinado ao roteador PE aonde está a rede de destino da VPN, não é necessário adicionar configuração. Mas caso o túnel seja destinado ao roteador P antes do PE de destino, é necessário habilitar o MPLS dentro da interface túnel na origem com o comando “mpls ip”.

1.5           Observações e Bugs

Documentação:

1.6           Comandos Importantes de Verificação

PE1#show ip cef vrf aqua
Prefix               Next Hop             Interface
0.0.0.0/32           receive
172.16.1.0/24        attached             FastEthernet1/0
172.16.1.0/32        receive
172.16.1.1/32        attached             FastEthernet1/0
172.16.1.2/32        receive
172.16.1.255/32      receive
172.16.13.0/24       10.5.5.5             Tunnel0
224.0.0.0/4          drop
224.0.0.0/24         receive
255.255.255.255/32   receive

PE1#show mpls ldp neighbor
    Peer LDP Ident: 10.3.3.3:0; Local LDP Ident 10.2.2.2:0
        TCP connection: 10.3.3.3.11056 - 10.2.2.2.646
        State: Oper; Msgs sent/rcvd: 57/57; Downstream
        Up time: 00:41:24
        LDP discovery sources:
          FastEthernet0/0, Src IP addr: 10.7.7.7
        Addresses bound to peer LDP Ident:
          10.7.7.7        10.3.3.3        10.8.8.7       
    Peer LDP Ident: 10.5.5.5:0; Local LDP Ident 10.2.2.2:0
        TCP connection: 10.5.5.5.11045 - 10.2.2.2.646
        State: Oper; Msgs sent/rcvd: 56/56; Downstream
        Up time: 00:40:58
        LDP discovery sources:
          Targeted Hello 10.2.2.2 -> 10.5.5.5, active
        Addresses bound to peer LDP Ident:
          10.5.5.5        10.8.8.5        10.12.12.1   

2        Configuração


2.1           CE1

!
interface FastEthernet1/0
 ip address 172.16.1.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 172.16.1.2
!

2.2           PE1

ip vrf aqua
 rd 100:1
 route-target export 1:1
 route-target import 1:1
!
mpls traffic-eng tunnels
!
interface Tunnel0
 ip unnumbered Loopback0
 mpls ip
 tunnel destination 10.5.5.5
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 dynamic
!        
interface Loopback0
 ip address 10.2.2.2 255.255.255.255
 ip router isis
!         
interface FastEthernet0/0
 ip address 10.7.7.2 255.255.255.0
 ip router isis
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth
!
interface FastEthernet1/0
 ip vrf forwarding aqua
 ip address 172.16.1.2 255.255.255.0
!
router isis
 net 47.1234.1111.1111.1111.00
 is-type level-1
 metric-style wide
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 10.11.11.11 remote-as 1
 neighbor 10.11.11.11 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.11.11.11 activate
!
 address-family vpnv4
 neighbor 10.11.11.11 activate
 neighbor 10.11.11.11 send-community extended
 !
 address-family ipv4 vrf aqua
 redistribute connected
!

2.3           P1

!
interface Loopback0
 ip address 10.3.3.3 255.255.255.255
 ip router isis
!
interface FastEthernet0/0
 ip address 10.8.8.7 255.255.255.0
 ip router isis
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth
!
interface FastEthernet1/0
 ip address 10.7.7.7 255.255.255.0
 ip router isis
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth
!
router isis
 net 47.1234.2222.2222.2222.00
 is-type level-1
 metric-style wide
 passive-interface Loopback0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1
!

2.4           P2

!
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 10.5.5.5 255.255.255.255
 ip router isis
!
interface FastEthernet0/0
 ip address 10.12.12.1 255.255.255.0
 ip router isis
 duplex full
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth
!
interface FastEthernet1/0
 ip address 10.8.8.5 255.255.255.0
 ip router isis
 duplex full
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth
!
router isis
 net 47.1234.3333.3333.3333.00
 is-type level-1
 metric-style wide
 passive-interface Loopback0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1
!

2.5           PE2

!
ip vrf aqua
 rd 100:1
 route-target export 1:1
 route-target import 1:1
!
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 10.11.11.11 255.255.255.255
 Ip router isis
!
interface FastEthernet0/0
 ip vrf forwarding aqua
 ip address 172.16.13.11 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.12.12.10 255.255.255.0
 ip router isis
 duplex full
 mpls traffic-eng tunnels
 mpls ip
 ip rsvp bandwidth
!
router isis
 net 47.1234.4444.4444.4444.00
 is-type level-1
 metric-style wide
 passive-interface Loopback0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1
!
router bgp 1
 neighbor 10.2.2.2 remote-as 1
 neighbor 10.2.2.2 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.2.2.2 activate
 !
 address-family vpnv4
 neighbor 10.2.2.2 activate
 neighbor 10.2.2.2 send-community extended
 !
 address-family ipv4 vrf aqua
 redistribute connected
!

2.6           CE2

!
interface FastEthernet1/0
 ip address 172.16.13.13 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 172.16.13.11
!

Nenhum comentário: