domingo, 13 de fevereiro de 2011

VPN - Inter-AS Opção B com troca de RT

1      Cenário

1.1       Objetivo

Oito roteadores (CE1, PE1, P1, PE2, PE3, P2, PE4 e CE2) são conectados formando dois backbones com 3 roteadores e um CE conectado. Pede-se:
      O protocolo de roteamento de backbone PE1-P1-PE2 deverá ser o OSPF na área 0 com todas as interfaces divulgadas e com mBGP e LDP no AS 1 para tráfego das vpns VRFs. O Router-reflector deverá ser o P1;
      O protocolo de roteamento de backbone PE1-P1-PE2 deverá ser o EIGRP no AS 2 com todas as interfaces divulgadas e com mBGP e LDP no AS 2 para tráfego das vpns VRFs. O Router-reflector deverá ser o P2;
      O CE1 deverá pertencer a VRF BLUE (Route-target 1:1) com OSPF entre o CE1 e o PE1;
      O CE2 deverá pertencer a VRF RED (Route-target 2:2) com OSPF entre o CE2 e o PE4;
      Deverá existir conectividade entre esses CEs usando a conexão entre os PEs PE2 e PE3 com Inter-AS Opção B;
      O route-target deverá sempre ter  o AS no primeiro octeto, por exemplo no AS 1 todos os route-target importados e exportados deverão começar com 1 “1:xxx”.

1.2       Topologia

Figure-01:         Topologia

1.3       IOS utilizados

      CE1, PE1, P1, PE2, PE3, P2, PE4 e CE2 – c7200-k91p-mz.122-25.S15.bin

1.4       Configuração dos Roteadores

1.4.1    Configurações do EIGRP do Backbone

Em todos os roteadores configura-se o roteamento EIGRP pelo comando “router eigrp ” onde o “AS” é o Autonomous System que deverá ser igual em todos os roteadores do mesmo domínio. O roteador também possui um router ID único que é configurado pelo comando “eigrp router-id ” dentro das configurações de roteamento.
Uma interface fica habilitada a fazer vizinhança quando a rede pertencente aquela interface está no comando “network ” está configurado no routeamento EIGRP. Caso seja necessário divulgar a rede da interface mas não habilita-la para fazer vizinhança EIGRP, usa-se o “passive-interface ” dentro das configurações de roteamento EIGRP.
Por padrão o EIGRP sumariza automaticamente as rotas para o seu vizinho. Pode-se cancelar essa sumarização automática com o comando “no auto-summary”. Desabilitar essa auto sumarização é comum para evitar loops em redes não planejadas, porém a tabela fica maior.

1.4.2    Configurações do OSPF do Backbone

Em todos os roteadores configura-se o roteamento OSPF pelo comando “router ospf ” onde o “processo” é um numero do processo OSPF. O roteador também possui um router ID único que geralmente é a interface loopback ou então o maior endereço IP do roteador.
Para adicionar interfaces deve-se usar o comando “network
área ”. Um roteador pode ter interfaces em áreas distintas, define-se cada área pelo comando network.
Para o roteador fazer vizinhança OSPF é necessário que a rede da interface esteja no comando “network” e a interface não esteja configurada como “passive-interface”.

1.4.3    Configurações do MPLS

Antes de qualquer configuração, o Cisco Express forwarding deve ser habilitado com o comando “ip cef”. Para habilitar o MPLS no modo LDP, usa-se o comando global “mpls label protocol ldp”.

1.4.4    Configuração do MBGP

Para estabelecer uma VPN é necessário configurar o MBGP para a troca de informações de prefixos de VPN. Pode-se somente configurar o MBGP nos roteadores PEs da rede que possuem conexão com os CEs, ou seja, conectados diretamente aos sites.
O MBGP funciona como o BGP, configura-se em todos os roteadores pelo comando “router bgp onde o “AS” é o Autonomous System do backbone. Dentro da configuração de BGP adicionam-se os vizinhos estaticamente com o comando “neighbor remote-as .
Adiciona-se o IP da interface loopback como Router-ID pelo comando “bgp router-id .
Como os roteadores dentro do mesmo AS não divulgarão as rotas IBGP entre eles, faz-se o full-mesh de conexão MBGP ou configuram-se os roteadores centrais como Router-reflectors adicionando os demais roteadores como clientes pelo comando “neighbor router-reflector-client”.
O MBGP é configurado dentro do protocolo BGP, porém deve-se separar a família de roteamento com o comando “address-family vpnv4”. Para o envio de prefixos das VPNs, deve-se habilitar o envio de community extendida com o comando “neighbor send-community extended”.
Todos os recursos como route-map, next-hop-self, router-reflector, etc. podem ser configurados dentro da família VPNv4 para manipular ou resolver problemas de roteamento.

1.4.5    Criando uma VPN VRF no BGP

Após todos os roteadores PEs da rede possuem conectividade MBGP, ou diretamente ou por router-reflector, cria-se a VPN com o comando “ip vrf ”, dentro desse comando ficam os parâmentros de marcação da VPN e das communities associadas aos prefixos daquela VPN. Configura-se o Route-Distinguisher da VPN, que deve ser único na rede, com comando “rd :”, e também cria-se a  community que será exportada para aqueles prefixos de rede com o comando “route-target :”, onde “import” significa importar as rotas e “export” exportar as rotas.
Cria-se então uma address-family dentro do BGP com o comando “address-family ipv4 vrf ” com o mesmo nome da VPN criada no “ip vrf” fora do roteamento BGP. Dentro dessa address-family são configuradas as redes que serão redistribuídas para os outros sites. Para divulgar as redes é necessário que a rede exista na tabela de roteamento interna e, ou adicionar o comando “network mask ou redistribuindo rotas para o MBGP com o comando “redistribute , que pode ser vinculado à um route-map para definir exatamente as rotas que serão divulgadas de um protocolo para outros sites.
Enfim, para que uma interface conectada ao CE faça parte da VPN BGP, usa-se o comando “ip vrf forwarding ” dentro da interface.

1.4.6    Habilitando o OSPF dentro da VPN VRF

O protocolo OSPF VRF é configurado com o comando “router ospf vrf ”. Dentro do roteamento configuram-se os parâmetros do OSPF, como o router-id e a redistribuição do BGP.

1.4.7    Configuração do Inter-AS Opção B

A opção B do Inter-AS usa uma conexão MBGP entre os roteadores ASBR para a troca de informações de prefixos de VPN. Pode-se acordar os mesmos RD e RT ou exportar e importar os RTs do AS vizinho, caso sejam diferentes. Na configuração do MBGP deve-se adicionar o “next-hop-self” na vizinhança com o router-reflector para que o ASBR seja o hop de saída das redes desconhecidas pelo AS local. Uma outra opção é colocar o nexct-hop-self na vizinhança com o outro AS, mas para isso o IP de loopback do ASBR do AS vizinho deverá ser conhecido dentro do AS local.
Deve-se também desabilitar o filtro de route-target do AS no BGP de borda com o AS vizinho usando o comando “no bgp default route-target filter” .
Na interface de interconexão deve-se adicionar o comando para habilitar o mpls BGP “mpls bgp forwarding”.

1.5       Observações e Bugs

Documentação:

1.6       Comandos Importantes de Verificação



2      Configuração


2.1       CE1

!
interface Loopback0
 ip address 101.101.101.101 255.255.255.255
!
interface FastEthernet1/0
 ip address 10.10.10.1 255.255.255.0
!
router ospf 101
 network 0.0.0.0 255.255.255.255 area 0
!

2.2       PE1

!
ip cef
!
ip vrf BLUE
 rd 1:1
 route-target export 1:1
 route-target import 1:1
 route-target import 1:2
!
mpls ldp router-id Loopback0
mpls label protocol ldp
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 11.11.11.1 255.255.255.0
 mpls ip
!
interface FastEthernet1/0
 ip vrf forwarding BLUE
 ip address 10.10.10.254 255.255.255.0
!
router ospf 101 vrf BLUE
 redistribute bgp 1 subnets
 network 10.10.10.254 0.0.0.0 area 0
!
router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 11.11.11.1 0.0.0.0 area 0
!
router bgp 1
 neighbor 100.100.100.100 remote-as 1
 neighbor 100.100.100.100 update-source Loopback0
 !
 address-family vpnv4
 neighbor 100.100.100.100 activate
 neighbor 100.100.100.100 send-community extended
 !
 address-family ipv4 vrf BLUE
 redistribute ospf 101 vrf BLUE match internal external 1 external 2
!

2.3       P1

!
ip cef
!
interface Loopback0
 ip address 100.100.100.100 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.100 255.255.255.0
 mpls ip
!
interface FastEthernet1/0
 ip address 11.11.11.100 255.255.255.0
 mpls ip 
!
router ospf 1
 router-id 100.100.100.100
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 1
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
!
 address-family vpnv4
 neighbor 1.1.1.1 activate
 neighbor 1.1.1.1 route-reflector-client
 neighbor 1.1.1.1 send-community extended
 neighbor 2.2.2.2 activate
 neighbor 2.2.2.2 route-reflector-client
 neighbor 2.2.2.2 send-community extended
 neighbor 2.2.2.2 route-map RT-CHANGE in
!
ip extcommunity-list 1 permit rt 2:2
ip extcommunity-list standard RT-VPN-RED permit rt 2:2
!
!
!
route-map RT-CHANGE permit 10
 match extcommunity RT-VPN-RED
 set extcomm-list 1 delete
 set extcommunity rt  1:2
!

2.4       PE2

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.2 255.255.255.0
 duplex full
 mpls bgp forwarding
!
interface FastEthernet1/0
 ip address 12.12.12.2 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 2.2.2.2
 passive-interface FastEthernet0/0
 network 2.2.2.2 0.0.0.0 area 0
 network 12.12.12.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0
!
router bgp 1
 no bgp default route-target filter
 neighbor 23.23.23.3 remote-as 2
 neighbor 100.100.100.100 remote-as 1
 !
 address-family ipv4
 neighbor 23.23.23.3 activate
 neighbor 100.100.100.100 activate
 no auto-summary
 no synchronization
 exit-address-family
 !       
 address-family vpnv4
 neighbor 23.23.23.3 activate
 neighbor 23.23.23.3 send-community extended
 neighbor 100.100.100.100 activate
 neighbor 100.100.100.100 next-hop-self
 neighbor 100.100.100.100 send-community extended
!

2.5       PE3

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 32.32.32.3 255.255.255.0
 mpls ip
!
interface FastEthernet1/0
 ip address 23.23.23.3 255.255.255.0
 mpls bgp forwarding
!
router eigrp 2
 passive-interface FastEthernet1/0
 network 3.3.3.3 0.0.0.0
 network 23.23.23.3 0.0.0.0
 network 32.32.32.3 0.0.0.0
 no auto-summary
 eigrp router-id 3.3.3.3
!
router bgp 2
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 23.23.23.2 remote-as 1
 neighbor 200.200.200.200 remote-as 2
 neighbor 200.200.200.200 update-source Loopback0
!
 address-family vpnv4
 neighbor 23.23.23.2 activate
 neighbor 23.23.23.2 send-community extended
 neighbor 200.200.200.200 activate
 neighbor 200.200.200.200 next-hop-self
 neighbor 200.200.200.200 send-community extended
!

2.6       P2

!
ip cef
!
mpls ldp router-id Loopback0
mpls label protocol ldp
!
!
interface Loopback0
 ip address 200.200.200.200 255.255.255.255
!
interface FastEthernet0/0
 ip address 24.24.24.200 255.255.255.0
 mpls ip
!
interface FastEthernet1/0
 ip address 32.32.32.200 255.255.255.0
 mpls ip 
!
router eigrp 2
 network 24.24.24.200 0.0.0.0
 network 32.32.32.200 0.0.0.0
 network 200.200.200.200 0.0.0.0
 no auto-summary
 eigrp router-id 200.200.200.200
!
router bgp 2
 neighbor 3.3.3.3 remote-as 2
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 2
 neighbor 4.4.4.4 update-source Loopback0
!
 address-family vpnv4
 neighbor 3.3.3.3 activate
 neighbor 3.3.3.3 route-reflector-client
 neighbor 3.3.3.3 send-community extended
 neighbor 3.3.3.3 route-map RT-CHANGE in
 neighbor 4.4.4.4 activate
 neighbor 4.4.4.4 route-reflector-client
 neighbor 4.4.4.4 send-community extended
!
!
ip extcommunity-list 1 permit rt 1:1
ip extcommunity-list standard RT-VPN-BLUE permit rt 1:1
!
!
!
route-map RT-CHANGE permit 10
 match extcommunity RT-VPN-BLUE
 set extcomm-list 1 delete
 set extcommunity rt  2:1
!

2.7       PE4

!
ip cef
!
ip vrf RED
 rd 2:2
 route-target export 2:2
 route-target import 2:2
 route-target import 2:1
!
mpls ldp router-id Loopback0
mpls label protocol ldp
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding RED
 ip address 20.20.20.254 255.255.255.0
!
interface FastEthernet1/0
 ip address 24.24.24.4 255.255.255.0
 mpls ip
!
router eigrp 2
 network 4.4.4.4 0.0.0.0
 network 24.24.24.0 0.0.0.255
 eigrp router-id 4.4.4.4
!
router ospf 102 vrf RED
 log-adjacency-changes
 redistribute bgp 2 subnets
 network 20.20.20.254 0.0.0.0 area 0
!
router bgp 2
 neighbor 200.200.200.200 remote-as 2
 neighbor 200.200.200.200 update-source Loopback0
!
 address-family vpnv4
 neighbor 200.200.200.200 activate
 neighbor 200.200.200.200 send-community extended
 !
 address-family ipv4 vrf RED
 redistribute ospf 102 vrf RED match internal external 1 external 2
!

2.8       CE2

!
interface Loopback0
 ip address 102.102.102.102 255.255.255.255
!
interface FastEthernet1/0
 ip address 20.20.20.2 255.255.255.0
!
router ospf 101
 network 0.0.0.0 255.255.255.255 area 0
!

2 comentários:

Anônimo disse...

http://prixviagrageneriquefrance.net/ viagra prix
http://commanderviagragenerique.net/ viagra achat
http://viagracomprargenericoespana.net/ viagra
http://acquistareviagragenericoitalia.net/ costo viagra

Anônimo disse...

http://achatcialisgenerique.lo.gs/ acheter cialis
http://commandercialisfer.lo.gs/ commander cialis
http://prezzocialisgenericoit.net/ dove acquistare cialis
http://preciocialisgenericoespana.net/ cialis venta