sábado, 15 de maio de 2010

EIGRP - Manipulação de Métrica


1        Teoria EIGRP

O EIGRP usa o minimo de banda no caminho para a rede de destino e o delay total para computer a métrica de roteamento. Pode-se também configurar outras métricas, não é recomendado, pois pode ocasionar loops de rede. A banda e o delay são metricas determinadas nopor valores configurados nas interfaces do roteador.
O update do EIGRP contem cinco métricas: menor bandwidth, delay, load, reliability, and maximum transmission unit (MTU). O EIGRP calcula a metrica total com os valores das métricas de bandwidth e delay por padrão, usando a formula:
bandwidth = (10000000/bandwidth(kbits)) * 256
delay = delay(ms) * 256
EIGRP usa essas formulas associada a formula abaixo para definer a métrica total:
metric = [K1 * bandwidth + (K2 * bandwidth) / (256 - load) + K3 * delay] * [K5 / (reliability + K4)]
Esses valores de K devem ser usados com cuidado no planejamento. Os valores default dos K são:
      K1 = 1
      K2 = 0
      K3 = 1
      K4 = 0
      K5 = 0
Simplificando a formula para: metric = bandwidth + delay


2        Cenário

2.1           Objetivo

Cinco roteadores (R1, R2, R3, R4 e R5) são conectados conforme a topologia abaixo e devem ser configurados seguindo os seguintes critérios.
·         Todos os roteadores deverão pertencer a uma rede EIGRP com AS = 1;
·         Todos os roteadores deverão usar suas interfaces loopbacks como Router-ID;
·         O tráfego do R1 para o IP 5.5.5.5 deverá ser encaminhado pelo R3;
·         O tráfego do R1 para o IP 6.6.6.6 deverá ser encaminhado pelo R4.
·         A auto sumarização deverá ser desabilitada.

2.2           Topologia

Figure-01:              Topologia

2.3           IOS utilizados

·         R1, R2, R3, R4 e R5 – c7200-js-mz.123-7.T.bin

2.4           Configuração dos Roteadores

Em todos os roteadores configura-se o roteamento EIGRP pelo comando “router eigrp ” onde o “AS” é o Autonomous System que deverá ser igual em todos os roteadores do mesmo domínio. O roteador também possui um router ID único que é configurado pelo comando “eigrp router-id ” dentro das configurações de roteamento.
Uma interface fica habilitada a fazer vizinhança quando a rede pertencente aquela interface está no comando “network ” está configurado no routeamento EIGRP. Caso seja necessário divulgar a rede da interface, mas não habilita-la para fazer vizinhança EIGRP, usa-se o “passive-interface ” dentro das configurações de roteamento EIGRP.
Por padrão o EIGRP sumariza automaticamente as rotas para o seu vizinho. Pode-se cancelar essa sumarização automática com o comando “no auto-summary”. Desabilitar essa auto sumarização é comum para evitar loops em redes não planejadas, porém a tabela fica maior.

2.4.1      Controle de rotas no EIGRP com OFF-SET


2.5           Observações e Bugs

Documentação:

2.6           Comandos Importantes de Verificação

R2#sh ip route                
Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/2297856] via 10.1.1.1, 00:00:29, Serial1/0.1
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/156160] via 10.1.2.3, 00:00:34, FastEthernet0/0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/156160] via 10.1.2.4, 00:00:29, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
D       5.5.5.5 [90/158720] via 10.1.2.3, 00:00:29, FastEthernet0/0
     6.0.0.0/32 is subnetted, 1 subnets
D       6.6.6.6 [90/158720] via 10.1.2.4, 00:00:29, FastEthernet0/0
     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/30720] via 10.1.2.4, 00:00:30, FastEthernet0/0
                 [90/30720] via 10.1.2.3, 00:00:30, FastEthernet0/0
C       10.1.2.0 is directly connected, FastEthernet0/0
C       10.1.1.0 is directly connected, Serial1/0.1

3        Configuração

3.1           R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial1/0
 encapsulation frame-relay IETF
 frame-relay intf-type dce
!
interface Serial1/0.1 point-to-point
 ip address 10.1.1.1 255.255.255.0
 frame-relay interface-dlci 102 

router eigrp 1
 network 0.0.0.0
 no auto-summary
 eigrp router-id 1.1.1.1
!

3.2           R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.2 255.255.255.0
!
interface Serial1/0
 encapsulation frame-relay IETF
!
interface Serial1/0.1 point-to-point
 ip address 10.1.1.2 255.255.255.0
 frame-relay interface-dlci 102  
!
router eigrp 1
 network 0.0.0.0
 no auto-summary
 eigrp router-id 2.2.2.2
!

3.3           R3

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.3 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.1.3.3 255.255.255.0
 !
router eigrp 1
 offset-list 1 out 1000
 network 0.0.0.0
 no auto-summary
 eigrp router-id 3.3.3.3
!
access-list 1 permit 6.6.6.6
!

3.4           R4

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.4 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.1.3.4 255.255.255.0
!
router eigrp 1
 offset-list 1 out 1000
 network 0.0.0.0
 no auto-summary
 eigrp router-id 4.4.4.4
!
access-list 1 permit 5.5.5.5
!

3.5           R5

!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet1/0
 ip address 10.1.3.5 255.255.255.0
!
router eigrp 1
 network 0.0.0.0
 no auto-summary
 eigrp router-id 5.5.5.5
!

 

Um comentário:

Renato Antonio disse...

Bruno, muito legal sempre acompanho seus pots estou caminhando para CCNP então aguardo a continuação sobre EIGRP, abraço.